Ricerca in FOLBlog

Windows 7 e fastidioso problema con le icone

 Scritto da alle 01:15 del 12/11/2009  Aggiungi commenti
nov 122009
 
closeQuesto articolo è stato pubblicato 4 anni 5 mesi 12 giorni giorni fa quindi alcuni contenuti o informazioni presenti in esso potrebbero non essere più validi.

Windows 7
Sul mio PC ho installato Windows 7 64 bit fin dall’uscita della prima beta.
Ho proceduto poi con l’installazione delle versioni seguenti, fino a quella definitiva, con successivi aggiornamenti.
Di recente ho anche reinstallato Windows 7 64bit partendo da zero, dopo aver creato sull’hd una partizione ad hoc per poterlo ospitare.
Ho poi installato Window 7 32bit su vari altri computer, e più volte (per fare dei test) sul mio Asus EeePC 1101-HA.
Ora sui miei PC gira Windows 7 a 32 o 64 bit installato partendo da zero.

In tutti i computer che ho avuto modo di osservare abbastanza a lungo si verifica, in modo del tutto casuale, il problema della sparizione delle icone dal desktop al riavvio del PC.
Per ripristinarne la visualizzazione l’operazione è semplicissima: occorre fare click con il tasto destro del mouse sul desktop e scegliere Visualizza->Mostra icone del desktop
Visualizza->Mostra icone del desktop

Un altro problema che si verifica sia sul computer in cui ho installato Windows 7 64bit che sul EeePC in cui gira Windows 7 32bit è quello del errato rendering di alcune icone (il perchè il problema si presenti solo su alcune icone non mi è ancora chiaro) quando si sceglie di visualizzarle di dimensione media (impostazione di default, tra l’altro), che vengono rappresentate “bucate” da un quadrato nero (le cui dimensioni, a naso, sono quelle dell’icona quando è visualizzata piccola).
image

Questo problema si è presentato solo dopo l’installazione della versione RTM (la definitiva) di Windows 7.
Il fatto che si presenti su macchine completamente diverse, versioni di sistema operativo diverso e a prescindere che si tratti di una clean install o un aggiornamento a Windows 7, mi fa sospettare che ci sia qualche bug nella gestione della cache riservata alla icone.

Per visualizzare nuovamente correttamente le icone occorre prima ridurle al minimo (click col tasto destro del mouse sul desktop e Visualizza->Icone piccole)….
Mostra icone piccole
Icone piccole visualizzate correttamente

…e poi rifare l’operazione scegliendo di visualizzare le icone medie o grandi. (click col tasto destro del mouse sul desktop e Visualizza->Icone medie).
Icone medie visualizzate correttamente

Il problema, in questo modo, non è risolto: è’ sufficiente il refresh del desktop perché si ripresenti (basta ad esempio cliccare con il tasto destro sul desktop e scegliere Aggiorna).

E’ da un po’ che tengo d’occhio entrambi i problemi nel tentativo di capirne l’origine o le correlazioni, senza esito.
Qualche suggerimento? Qualche ipotesi?

Technorati Tag: ,


Articoli simili:

  • Facebook
  • Twitter
  • Delicious
  • StumbleUpon
  • Wikio
  • Reddit
  • Technorati
  • Segnalo
  • Live
  • Add to favorites
  • Email
  • RSS

  14 Risposte a “Windows 7 e fastidioso problema con le icone”

Commenti (14)
  1. Usando Internet Explorer Internet Explorer 8.0 con Windows Windows 7

    Mi sembra che accada ad alcune icone anzichè ad altre.
    Hai provato a fare tu un’icona apposta e sostituirla e vedere che accade?

  2. Usando Mozilla Firefox Mozilla Firefox 3.5.5 con Windows Windows 7

    Le icone che spariscono per quanto ho capito riguardano in qualche modo il cambio di stato dell’alimentazione, se si arresta, poi si iberna ed in base se il tutto avviene collegati alla rete o solo con la batteria.

    Forse se evitavano di mettere l’opzione il problema non si presentava neppure :mrgreen:

  3. Usando Mozilla Firefox Mozilla Firefox 3.5.5 con Windows Windows 7

    NickelGreen ha scritto:

    Mi sembra che accada ad alcune icone anzichè ad altre.
    Hai provato a fare tu un’icona apposta e sostituirla e vedere che accade?

    Qualsiasi icona io selezioni per quei collegamenti presenti sul desktop (quelli con le icone “bucate”), viene mostrata con il difetto.

    Ho scoperto anche un’altra cosa: creando manualmente un collegamento sul desktop, qualsiasi nuova icona viene presentata con il difetto.
    Se ad esempio creo un collegamento a “Computer” la cui icona è renderizzata correttamente sul desktop, l’icona associata al nuovo collegamento creato è…bacata!
    Perciò sul desktop ho il collegamento Computer “originale” che mostra l’icona correttamente, e il collegamento appena creato che invece mostra l’icona “bucata” (o bacata o buggata…).

    Ho anche provato a resettare la cache delle icone (due metodi son spiegati qui) senza nessun risultato.

  4. Usando Mozilla Firefox Mozilla Firefox 3.5.5 con Windows Windows 7

    Ho scoperto l’origine del bug delle icone bucate:
    Il bug è legato alla scelta della dimensione personalizzata del testo (tasto destro sul desktop, Personalizza->Schermo->Impostazione dimensione testo personalizzata (DPI) ).

    Selezionando un valore di DPI tra quelli predefiniti (100%, 125% o 150%) dalle impostazioni dello schermo, il problema non si presenta.
    Nel mio PC il DPI era impostato al 110% e questo causa la scorretta visualizzazione di alcune icone.
    Ho sempre usato quel valore di DPI sui miei PC. Il problema di visualizzazione è arrivato solo con la versione RTM di Windows 7.

  5. Usando Internet Explorer Internet Explorer 8.0 con Windows Windows 7

    E’ la versione italiana di Windows 7 o la versione inglese + language pack?
    Hai avuto lo stesso problema su qualche installazione in inglese?

  6. Usando Mozilla Firefox Mozilla Firefox 3.5.5 con Windows Windows 7

    EnricoG ha scritto:

    E’ la versione italiana di Windows 7 o la versione inglese + language pack?
    Hai avuto lo stesso problema su qualche installazione in inglese?

    Ora è la versione italiana.
    Ma lo stesso problema lo avevo quando utilizzavo la versione inglese con language pack.

  7. Usando Internet Explorer Internet Explorer 8.0 con Windows Windows 7

    Con che scheda video?
    Te lo chiedo perche’ ho provato a mettere il DPI a 110% sul MacBook (Intel X3100) e sta funzionando senza mostrare problemi alle icone, ho fatto un paio di reboot, creato shortcut etc ma sembra tutto a posto. Ma uso la versione inglese senza language pack… non vorrei mai fosse un problema legato alla localizzazione.

  8. Usando Internet Explorer Internet Explorer 8.0 con Windows Windows XP

    io invece stamane ho lanciato l’installazione di seven professional in aggiornamento a vista business.
    Mi ha subito chiesto la connessione a internet, e ora è fermo su “arresto in corso” da almeno 3 ore….. si starà scaricando un dvd aggiornato???

    il dvd dentro è originale…..

  9. Usando Mozilla Firefox Mozilla Firefox 3.5.5 con Windows Windows 7

    EnricoG ha scritto:

    Con che scheda video?

    DA una parte Radeon X1950 512MB, dall’altra la GMA500 integrata dell’EeepC

  10. Usando Internet Explorer Internet Explorer 8.0 con Windows Windows 7

    @Sting… ti sconsiglio vivamente l’aggiornamento, fai l’installazione da zero.
    Altra cosa, se proprio vuoi fare l’aggiornamento, stacca prima il PC dalla rete, c’e’ un noto problema con l’aggiornamento che tenta di controllare se ce’ qualche patch da scaricare dalla rete e si pianta.

    @Enrico
    direi che si puo’ escludere la dipendenza dalla scheda video, resta la questione language pack, io intanto ho lasciato il DPI a 110% sul MacBook, vediamo se prima o poi si presenta il problema.

  11. Usando Internet Explorer Internet Explorer 8.0 con Windows Windows XP

    @EnricoG
    volevo vedere se funzionava l’aggiornamento con tutti i programmi, x fare da betatester al pc della fidanzata (che se poi da dei problemi sono tutti c@zzi miei….).
    Ho spento il portatile brutalmente, l’ho riavviato, tutto ok!
    Persino Office non da problemi.

    Confermo:
    l’aggiornamento su vista business a seven professiona funziona :)

  12. Usando Internet Explorer Internet Explorer 8.0 con Windows Windows 7

    a me invece si presenta diversamente
    oni settimana diventano tt i colori alterati e poi tt le icone abnormi ma senza il “buco nero” non so più che fare ora sto scrivendo con le dimensioni alterate e tt sfocato ma con i colori mìnormali
    io la risolvevo spostando il mio pc in cucina e poi si risolveva ma iavviando mettendo in modalità provvisoria ed altro nn riesco a risolverla spero ne vostro aiuto
    grazie

  13. Usando Internet Explorer Internet Explorer 8.0 con Windows Windows 7

    ciao raga, anch io ho un problema spero che qualcuno di voi possa darmi una dritta, con windows xp quando creavo una cartella con una serie di episodi di cartoni animati , tali episodi riuscivo a metterli in ordine di numero di episodio , cosa che con windows 7 nn riesco, nn mi da la possibilita di spostarli in nessuna maniera . con xp se clicco su visualizza c è la voce “disposizione automatica” , invece su w.7 nn c è questa voce .Qualcuno sa dirmi come fare? grazie.

  14. Usando Mozilla Firefox Mozilla Firefox 10.0.2 con Windows Windows 7

    il quadrato nero,sulle icone dipende probabilmento dalla grandezza dello schermo personalizzato:tasto destro (personalizza/schermo/spuntare l’opzione consigliata)

 Lascia un commento

(richiesto)

(richiesto)

Puoi usare questi tag e attributi HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

%d blogger cliccano Mi Piace per questo: