Privacy Policy [FOLBlog] Utilizzare estensioni di Firefox 2 su Firefox 3 (aggiornato) (di enrico)

Ricerca in FOLBlog

Mag 272008
 

image Non ho resistito alla tentazione ed ho installato Firefox 3 RC1, nonostante non sia stato ancora rilasciato in versione definitiva.

La curiosità ha avuto il sopravvento anche sulla consapevolezza che probabilmente avrei dovuto rinunciare a molte delle estensioni (aka  componenti aggiuntivi, add-ons) che tanto mi hanno fatto apprezzare Firefox e che son la vera ragione per cui lo preferisco ad altri browser.

Dopo l’installazione, ahimè, ho dovuto constatare che, effettivamente, molte estensioni installate non risultavano compatibili con Firefox 3 e che non esistevano ulteriori aggiornamenti.
E’ stata, è vero, l’occasione giusta per disinstallare alcune estensioni che probabilmente non ho mai usato e che credo non avrei utilizzato nemmeno in futuro, ma per alcuni giorni ho atteso invano che, all’avvio, Firefox mi segnalasse la presenza di aggiornamenti di quelle che più mi mancavano:
Hyperwords di cui faccio veramente fatica a fare a meno ora che ho preso l’abitudine di averlo a disposizione;
Tab Mix Plus, che trovo utilissimo per personalizzare il comportamento di Firefox con le schede (TAB);
Delicious Bookmark, che consente di gestire al meglio i propri bookmarks del.icio.us

Alla fine non ho avuto la pazienza di aspettare e mi son messo alla ricerca di una soluzione. E l’ho trovata!
Son partito con una ricerca su Fasterfox, perchè uno dei più diffusi plugin per Firefox, in grado di aumentare la velocità di navigazione grazie ad alcune ottimizzazioni (anche se, a naso, Firefox 3 sembra averne scarso bisogno).

Sono incappato in un articolo che spiega come fare in modo che Firefox non consideri incompatibili i plugin:
1) scaricare l’xpi, cioè il file che installa il plugin che interessa (si tratta di un file compresso che può essere aperto tranquillamente con un compressore come 7zip o WinRAR)
2) editare il file install.rdf (contenuto nell’ xpi) con un editor di testo
3) cercare la sezione <em:targetApplication> e al suo interno il valore em:maxVersion. Modificare il valore da 2.0.0.* a 3.0.0, (oppure 3.0.1 😉 ) quindi salvare e chiudere il file
4) inserire nuovamente il file nell’archivio xpi e sovrascrivere il precedente e poi installare il plugin

Per installare il plugin è sufficiente trascinare il file xpi nella finestra “Componenti Aggiuntivi” che si apre selezionando l’apposita voce del menu “Strumenti” di Firefox 3:
image

Questo trucco consente di installare il plugin ma, ovviamente, non ne garantisce il perfetto funzionamento.
Fasterfox sembra funzionare correttamente.

Ho poi utilizzato lo stesso trucco per installare Delicious Bookmark. Anche questo plugin funziona perfettamente.
image

Per Tab Mix Plus invece ho scoperto che esiste una versione beta (Tab Mix Plus Dev-Build) per Firefox 3; dato che non  mi non spaventa l’utilizzo di beta su RC 😉 ho scaricato il file xpi e l’ho installato. Funziona benissimo.

Ma la cosa che più mi a fatto contento è scoprire che, nonostante Firefox non ne segnalasse la presenza, esiste una versione di Hyperwords che funziona perfettamente con Firefox 3!!

Ho completato l’opera scaricando l’ultima versione di MozBackup (fino ad ora avevo utilizzato la versione 1.4.8 alpha), l’utilissimo tool che consente il backup ed il ripristino delle impostazioni di Firefox, Thunderbird, SeaMonkey, Mozilla Suite e Netscape.
image

Finalmente ora posso utilizzare Firefox 3 senza rimpiangere nulla della versione precedente.

Technorati Tag: ,,,Fasterfox,Tab Mix Plus,Delicious Bookmark plugin,tips,howto

[ratings]

Articoli simili:

  9 Risposte a “Utilizzare estensioni di Firefox 2 su Firefox 3 (aggiornato)”

Commenti (6) Pingbacks (3)
  1. Usando Mozilla Firefox Mozilla Firefox 3.0 con Mac OS X Mac OS X 10

    Alcune note:

    1) Argh! Plugin?estensione (così come nella versione inglese plug-in?add-on). I plugin sono Java, Flash, ecc. ecc.

    2) In realtà quello che hai indicato è solo uno dei metodi usabili (ad esempio puoi modificare extensions.lastAppVersion in about:config, oppure Nightly Tester Tools), ma tutti questi accorgimenti hanno lo stesso difetto: l’estensione si installa perché vengono aggirati i controlli di versione, ma di qui a funzionare è un altro discorso.
    Se l’estensione è abbastanza complessa (vedi TabMix plus, Firebug ,ecc. ecc.) può appoggiarsi a funzioni che vengono modificate da una versione all’altra o addirittura rimosse, per cui forzare la compatibilità può portare a un profilo praticamente inutilizzabile 😉

    3) Perché usare uno strumento “opaco” (MozBackup) quando puoi farti una semplice copia della cartella del profilo? 😉

  2. Usando Mozilla Firefox Mozilla Firefox 3.0 con Windows Windows Vista

    @pseudotecnico
    1) pignolo!
    2) sul fatto che installare != funzionare sono stato chiaro nell’articolo, mi sembra.
    3) Perchè posso fare i backup sia di Firefox che di Thunderbird da riga di comando; questo mi consente di automatizzare il backup via scheduler

  3. Usando Mozilla Firefox Mozilla Firefox 3.0 con Mac OS X Mac OS X 10

    1) Preferisco “preciso” (in alternativa rompiballe). 😛
    Sinceramente spero che la presenza di una scheda “Plugin” a partire da Firefox3 contribuisca a eliminare la confusione sui termini, ma non ci spero troppo

    2) Preferivo sottolinearlo 😉

    3) Ti parlo per esperienza: ho perso il conto delle persone che hanno avuto problemi con MozBackup. Visto che si tratta della copia di una cartella (o di due cartelle se vuoi salvare anche Thunderbird), ti basta uno stupidissimo file batch per pianificare i backup 😉

  4. Usando Mozilla Firefox Mozilla Firefox 3.0 con Mac OS X Mac OS X 10

    [OT] Ma usi qualche plugin di WordPress per i commenti (o l’editor dei commenti)? Si è mangiato gli spazi nel commento precedente, e nel primo mi ha trasformato il simbolo “diverso” in un punto di domanda 🙁

  5. Usando Mozilla Firefox Mozilla Firefox 3.0 con Windows Windows Vista

    @PseudoTecnico
    No, nessun plugin; WordPress al naturale (per i commenti).

  6. Usando Mozilla Firefox Mozilla Firefox 3.0 con Linux Linux

    Funziona alla grande anche su Ubntu!!!

 Lascia un commento

Puoi usare questi tag e attributi HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(richiesto)

(richiesto)

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

%d blogger hanno fatto clic su Mi Piace per questo: